Updating the Free Linux Kernel on Trisquel GNU / Linux-libre

Linux as distributed by kernel.org contains proprietary software, and it induces you to install additional proprietary software that it doesn't contain.

Linux-libre is a modified version of Linux with all of the binary blobs, obfuscated code and portions of code under proprietary licenses removed.

The resulting combination of the GNU Operating System and the kernel named Linux is the GNU/Linux operating system, although many (incorrectly) refer to it as "Linux."

This repository contains .debs of Linux-libre compiled for 32- and 64-bit x86 CPUs. It should work with most any GNU/Linux distribution that uses APT. It's known to be compatible with Trisquel, gNewSense, Debian, Ubuntu, Devuan and their respective derivatives. Please contact me if you need support for additional CPU architectures or other GNU/Linux distributions.

I hope that this repository will make software freedom easier for more people, either by allowing you to replace the kernel in your existing GNU/Linux distribution with one that is entirely freedom-respecting, or for people already using fully-free GNU/Linux distributions to more easily get a newer kernel version if you need it for some reason.

To use this repository first add it to your system. Run this command:

$ sudo apt edit-sources

And add the line:

deb http://linux-libre.fsfla.org/pub/linux-libre/freesh/ freesh main

You should also fetch and install the GPG key with which the repository is signed:

Now you will now be able to update your package manager and install Linux-libre:

$ sudo apt update

The exact command to run next depends on how you want things to work. Please review all of the information below.

Current and upcoming kernel versions to know about:

Version

Status

Released

Supported Until

4.13

Future version, expected in September 2017.

4.12

Latest released version.

July 2017

September 2017

4.9

Current long-term support (LTS) version.

December 2016

January 2019

4.1

Previous long-term support (LTS) version, but still supported.

June 2015

September 2017

Please keep in mind that a new long-term support version is selected roughly once each year and then supported for at least two years. The next one will 4.14, which is expected in November 2017.

To determine if your CPU supports PAE (which is good to know for the chart below) run this command:

  $ grep –color=always -i PAE /proc/cpuinfo

If pae is highlighted in the output then your system supports PAE. Otherwise it does not.

Please continue reading to find the use case that most closely describes what you want.

Use Case

Command

"I always want the latest version of Linux-libre. No matter what."

sudo apt install linux-libre

Same as above, but I have an older computer that doesn't support PAE. (See the earlier note about PAE.)

sudo apt install linux-libre-nonpae

"I want the latest version of Linux-libre, but when 4.13 comes out as the next major new release I want to wait a bit before upgrading so that any problems can get sorted out. I'll decide when I'm ready to upgrade to 4.13, but I still want to get updates for 4.12 while I'm waiting."

sudo apt install linux-libre-4.12

Same as above, but I have an older computer that doesn't support PAE. (See the earlier note about PAE.)

sudo apt install linux-libre-4.12-nonpae

"I always want to be using the current long-term support (LTS) version of Linux-libre. No matter what."

sudo apt install linux-libre-lts

Same as above, but I have an older computer that doesn't support PAE. (See the earlier note about PAE.)

sudo apt install linux-libre-lts-nonpae

"I want to use the current long-term support (LTS) version of Linux-libre but when the next one (4.14) comes out in November 2017 I don't want to upgrade to it. I want to stay with the current LTS (4.9) until I decide otherwise."

sudo apt install linux-libre-4.9

Same as above, but I have an older computer that doesn't support PAE. (See the earlier note about PAE.)

sudo apt install linux-libre-4.9-nonpae

"I know that the current long-term support (LTS) version of Linux-libre is 4.9 but I want to keep using the previous LTS version (4.1) until I decide otherwise."

sudo apt install linux-libre-4.1

Same as above, but I have an older computer that doesn't support PAE. (See the earlier note about PAE.)

sudo apt install linux-libre-4.1-nonpae

If you use libreboot make sure to do this. If you do not use libreboot, skip this step.

$ cd /boot/grub
$ sudo ln -s grub.cfg libreboot_grub.cfg

 

Credits 01 | Credits 02